SWDTeam Forums

Welcome to the SWDTeam forums. Enjoy your stay!, Thank you for being part of our community!

I try to play 1.8 Dalek Mod multiplayer

It comes up with something named outdated client something.... how can I fix it?

1. There is no need to make two Threads, just wait for someone to respond to your first Thread.
2. Try explain the situation a little more, you're making it rather difficult for people to help you by not explaining what you're trying to do.
3. If you're problem is what I think it is, which is you're trying to connect to DMU using 1.8, then 1.8 is your problem. The Dalek Mod has since moved up to 1.12.2 as well as the servers so you need to install Forge for 1.12 and the latest DM update.

You must be logged in to post.

Contact us

support@swdteam.com