SWDTeam Forums

Welcome to the SWDTeam forums. Enjoy your stay!, Thank you for being part of our community!

TARDIS model glitch (update 58.1)

after updating to update 58.1, and having a lot of trouble even getting the game to just initialize, I noticed the Police Box exterior (all of them) have glitched models, with the 'Police Public Call Box' sign and the 'Pull to open' sign appearing... well... just wrong. This happened on all the Police Box exteriors, especially the War Doctor's, which is the exterior I mainly use. Other exterior's have various other glitches, like the Tree exterior has sections of leaves missing and random lines are missing though out the bark of the tree.


Below, you will see the glitch I am talking about on the War Doctor's Exterior. the signs appear different sizes and aspect ratios depending on what direction and distance I look at my TARDIS from


Other than that, I noticed the slabs dont actually drop when they're mined. I tried to move a few blocks out of my TARDIS Console, and a few out of my slab roof, but they didnt drop. I had to go buy more from the DMU Shop. (the problematic slabs so far are the Toyota Console and Toyota Roof slabs)


Having said that, I am very pleased with the rest of this new update. I no longer get lag on Mondas and I'm so happy to see the interior doors appearing correctly, I almost forgot how cool the Brachaki Doors look

I wast able to exactly recreate the glitch on the Tree extior that I described earlier, but I did find a different glitch. Where the bottom half off the tree vanishes when the door is opened





and I also noticed a similar glitch to the Police Box exteriors, but on the Gallifrey Falls painting. BTW, I play with BOTI off to save me from unnecessary lag, hence why this painting inst 3D



I've loaded every single TARDIS Exterior to see the extent of these glitches and they all have they're one unique model glitches. All the Doctor's Police Box exteriors (1st-13th, and Ruth's) have the same glitch. named TARDIS, like the Epsimo, Gizmo's, Ethosein's, the Blocktors, etc, looks perfectly fine, as do the Dalek mod Alpha- Gamma and Dalek mod A-D. Other TARDIS like the Hexon, vanilla (cobble, brick. and wood) and the Fridge exteriors look fine as well.

Below, you can see several screenshots off the TARDIS's with serious model glitches.  the Portal exterior doesn't show at all and the RGB exterior is too dark to notice anything (but it has similar glitches to the Pride Police Box), hence why there isnt a photo of that



Pride Police Box:


SB-129 Time Machine


EnderPortal (only visible when looking at it from a certain angle)




Valiant (both Blue and Orange veriants)


Vanilla Minecraft TARDIS


GrandFather Clock (only the face of the clock seemed to glitch)


Vending Machine (Pepsi logo looks swooshy...)


And lastly (so far), the Other Vanilla Minecraft TARDIS

Have you got any other mods installed which might be causing this? It looks like something could be interfering with the rendering

I dont use any other mods except the Dalek mod and JEI. But I do use shaders

(Complimentary Shaders, https://www.curseforge.com/minecraft/customization/complementary-shaders ) 

But I've been using this shader pack for several Dalek Mod updates, and 58.1 is the only one to have this problem. If it's possible that its just update 58.1 that my shaders dont like, I am happy to remove them. I'd rather have the Dalek mod working properly than having Minecraft look slightly more realistic XD.


If you have a link to the shaders used in the Dalek Mod videos on Youtube, that could help. because at least we know those shaders work

sooo, It turns out it was the shaders surprised

Sorry for assuming it was the update. Although, the shaders worked fine with previous updates.

Do you, perhaps, now what shaders are confirmed to work with The Dalek mod without glitches like this?


Edit: It turns out, it wasnt the Shaders as a whole. it was  a specific feature called 'PRB', Not sure what that feature means or even does, but I turned it off and my TARDIS looks normal.

Sorry again for blaming my mistake on The update.

Ther is also another glitch with the nocubes mod, if you walk on in a block you cannot move, specifically near a tardis. 

You must be logged in to post.